Главное окно

После запуска программы появится окно:

Окно состоит из двух частей:

Слева представлено дерево организаций, участков. Оно формируется автоматически - в результате ввода или передачи данных по пайщикам.
Для обновления дерева нажмите правую кнопку мыши и [image].

Центральная панель состоит из двух вкладок - Реестр Пайщиков и Отчеты.
Настройку отчетов см. Отчеты.
Настройку реестра см. Реестр.


Ввод пайщиков

Чтобы поставить на учет нового пайщика нужно зайти в главном меню в "Действия", далее "Прием пайщика" или на панели "Реестр пайщиков" нажать кнопку [image].

Перед тем как вводить пайщиков, обязательно должны быть заполнены атрибуты организации см. данные по организации
На экране появится карточка пайщика:

Карточка состоит из двух частей:
обязательные поля (слева)
дополнительные поля (справа).

Визуализацией дополнительных полей можно управлять с помощью кнопки [image].
Как заводить дополнительные поля смотрите в Дополнительные поля

Для облегчения можно переносить значения некоторых полей см. реестр пайщиков.

Заполнив все обязательные поля и если нужно дополнительные нажмите "Сохранить". В базу данных будет добавлен новый пайщик. Посмотрев историю вы увидите операцию "Прием пайщика":


Дополнить пай

Чтобы дополнить пай у пайщика нужно зайти в главном меню в "Действия", далее "Дополнить пай" или на панели "Реестр пайщиков" нажать кнопку [image].
На экране появится экранная форма:

Введя дату дополнения пая и сумму нажмите "Готово". Пай пополнится на указанную сумму. Операция будет отображена в истории пайщика:


Прекращение членства

Чтобы прекратить членство пайщика нужно зайти в главном меню в "Действия", далее "Прекращение членства" или на панели "Реестр пайщиков" нажать кнопку [image].
На экране появится экранная форма:

Введите дату расторжения и выберите причину выбытия из выпадающего списка:

Если требуется введите описание причины выбытия в поле "Ссылка на документ:"

Нажмите "Готово". Операция будет отображена в истории пайщика:


Откат операции

Чтобы отменить операцию нужно зайти в историю, выбрать операцию, нажать правую кнопку мыши и выбрать откат операции:

Операция будет отменена.


Передача данных

Чтобы передать данные по пайщикам в вышестоящую организацию, войдите в главном меню в "Прием/Передача" далее "Передача".
Будет создан (ZIP) архив с данными. Название архива состоит из названия вашей организации см. данные по организации и даты формирования файла.
Далее появится диалоговое окно сохранения:

По умолчанию каталог сохранения файла будет OutPut, который создастся в корневом каталоге программы PAY.
Также файл можно сохранить в любом другом каталоге.


Удаление пайщика

Чтобы удалить пайщика нужно зайти в главном меню в "Действия", далее "Удалить пайщика" или на панели "Реестр пайщиков" нажать кнопку [image].
Если по пайщику есть операции кроме приема пайщика то он не сможет быть удалён и будет выдано сообщение:

См. Откат операции

Если кроме постановки на учет нет никаких операций, то будет выдано сообщение:

После подтверждения пайщик будет удалён.


Данные по организации

Работа программы начинается с ввода атрибутов вашей организации: Главное меню, далее "Настройка", далее "Данные по организации".

После заполнения реквизитов организации, можно начинать вод пайщиков.


Дополнительные поля

Если пользователю недостаточно обязательных реквизитов пайщика и требуются его расширить то в программе предусмотрен режим ввода дополнительных полей.
Для его запуска в главном меню выбрать "Настройка" далее "Дополнительные поля" появится экранная форма:

Для ввода нового поля нажать на [image]. Заполнить:
системное имя поля (большими английскими буквами),
затем наименование (которое будет отображено в реестре и карточке),
указать тип поля.

Для удаления нажмите [image]. Если по полю уже вводились данные то появится предупреждение:


Подключение

Чтобы подключится к базе данных нужно в главном меню выбрать "Настройка" далее "Подключение", появится экранная форма:

Локальное подключение:
База данных "Pay.gdb" находится на рабочем месте, где установлена клиентская программа "Payschik.exe", по умолчанию в той же папке "Pay".
Если БД находится в другом каталоге, то выберите ее с помощью кнопки [image].

Сетевое подключение:

База данных и клиентская программа находятся на разных компьютерах соединенных сетью.
Нужно указать IP адрес сервера (на котором находится БД), затем вручную прописать путь к БД на сервере! Здесь важно не перепутать и написать путь к БД именно так как вы видите ее на сервере, а не через сетевое окружение со своего рабочего места!


Реестр пайщиков

Для настройки реестра пайщиков в главном меню выберите "Настройка" далее "Реестр пайщиков", появится окно:

В данном окне представлен список обязательных и дополнительных полей. Дополнительные поля выделены серым цветом.
Чтобы выбрать поля для отображения в реестре - нужно в колонке [image] отметить галочками нужные вам поля.

Также в данном окне можно настроить заполнение полей по умолчанию при добавлении нового пайщика. (Например чтобы не вводить всегда один и тот же адрес или другой реквизит). Для этого в колонке [image] нужно отметить галочками требуемые поля.

Границы полей можно менять в главном окне программы - установив курсор на границе поля и "потянув" в нужную сторону.
Очередность полей можно менять "потянув" за титул поля.
Сортировка по графе производится нажатием на ее титул. Нажав второй раз получите сортировку в обратном порядке.
Чтобы отсортировать реестр по нескольким графам, зажмите клавишу Ctrl и "щелкайте" по титулам граф.

Чтобы сузить границу столбца до минимального значения, нажмите правой кнопкой мыши на столбец, затем [image].


Реестр пайщиков

Отчет представляет из себя список пайщиков с суммой пая на указанную дату.

После запуска введите дату:

Отчет имеет вид:


Запуск отчетов

Для работы с отчетами нужно на правой панели выбрать вкладку "Отчеты":

Структура дерева отчетов это структура дерева каталогов в папке «Reports». Вы можете сами переименовывать файлы (*.frf), переносить их по каталогам, добавлять новые и все они появятся в программе аналогично дереву каталогов.

- запустить отчет,
- запустить дизайнер отчета,

- кнопка имеет 2 положения вкл/выкл. При включении отчеты будут печататься в ДОС кодировки - для МАТРИЧНЫХ принтеров.


Динамика численности

Динамика численности показывает движение числа пайщиков за указанный период по участкам:

количество пайщиков на начало периода,
количество пайщиков поставленных на учет за период,
количество пайщиков, выбывших за период,
количество пайщиков на конец периода.

Введите период и нажмите ОК. Отчет выглядит следующим образом:


Динамика паевого фонда

Динамика паевого фонда показывает движение суммы пая за указанный период по участкам:

сумма пая на начало периода,
сумма пая, поступившего за период,
сумма выданного за период,
сумма пая на конец периода.

Введите период и нажмите ОК. Отчет выглядит следующим образом:


Юбилейный

Отчет юбилейный показывает список пайщиков, которым исполнилось 50, 60, 70, 80, 90, 100 лет за указанный период:

Введите период и нажмите ОК. Отчет выглядит следующим образом:


Анализ выбытия

Отчет показывает сколько пайщиков и по каким причинам выбыло за указанный период времени.

Введите период и нажмите ОК. Отчет выглядит следующим образом:


Контроль данных реестра

Отчет показывает пайщиков, у которых не заполнены все обязательные поля или дата рождения превышает дату поступления на 16 лет:


Вид

Меню Вид состоит из следующих пунктов:

-Подвал реестра (вкл/выкл).

- Удаленные пайщики - отображать удаленных пайщиков (вкл/выкл). Удаленные будут показаны фиолетовым цветом:

- История операций - отображать историю операция по пайщику (вкл/выкл).